How to support php 5.6 and php 8 on Apache2.4+nginx

Started by Tegeran, Oct 21, 2022, 12:45 PM

Previous topic - Next topic

TegeranTopic starter

I have a new debian 11 and a standard Apache+nginx+Mariadb build on it.
Found documentation on how to build multiple php builds, but for some reason the latest versions.
How to build and make it work with the old php 5.6, and some sites on php 8.0. Difficulties start at the fact that the repositories are not php 5.6.

I would be grateful for tips.
  •  

_AnnA_

Here, on the Internet I came across an article on how to install: tecadmin.net/how-to-install-php-on-debian-11
Quite a comprehensive description, I think.
Well, or you can install from source.
  •  

SIROTA

Install a clean control panel that supports all versions of PHP.
For example, you can use FastPanel of the free ones. It is definitely there.

Move sites there.
Enjoy the work you have done.
You cannot view this attachment.
  •